Can't emerge Netbeans with ant 1.9+

0
No votes yet
Your rating: None

If it complains about incompatible types:

[javac] found   : java.util.Hashtable<java.lang.String,java.lang.Object>
[javac] required: java.util.Map<java.lang.String,java.lang.String>
[javac]         Map<String,String> properties = getProject().getProperties();
[javac]                                                                   ^

Just mask these packages (need downgrade to ant 1.8.x):

>=dev-java/ant-1.9
>=dev-java/ant-antlr-1.9
>=dev-java/ant-apache-bcel-1.9
>=dev-java/ant-apache-bsf-1.9
>=dev-java/ant-apache-log4j-1.9
>=dev-java/ant-apache-oro-1.9
>=dev-java/ant-apache-regexp-1.9
>=dev-java/ant-apache-resolver-1.9
>=dev-java/ant-apache-xalan2-1.9
>=dev-java/ant-commons-logging-1.9
>=dev-java/ant-commons-net-1.9
>=dev-java/ant-core-1.9
>=dev-java/ant-jai-1.9
>=dev-java/ant-javamail-1.9
>=dev-java/ant-jdepend-1.9
>=dev-java/ant-jmf-1.9
>=dev-java/ant-jsch-1.9
>=dev-java/ant-junit-1.9
>=dev-java/ant-junit4-1.9
>=dev-java/ant-nodeps-1.9
>=dev-java/ant-swing-1.9
>=dev-java/ant-testutil-1.9
>=dev-java/ant-trax-1.9

Source: http://forums.gentoo.org/…start-0.html (tamjan)

Keywords: Linux